Notifications
Clear all

2007 Dodge Ram 1500 TIPM or Instrument Cluster?

 
Paul Erickson
New Member Registered

Just purchased with electrical issues.  

Instrument Cluster: Fuel and Temp gauges not working and light is out on Temp gauge.

Other: No turn signals, wipers, washer or high beam (multi-function switch), radio. No manual headlights/parking lights or dimmer light

TIPM: Removed and cleaned connector pins and female side with DeOxit 5.  Inspected board under magnifying glass and did not see anything noticeable.  

Grounded out positive and negative battery terminals for 45 minutes.  Lost radio and above windshield navigation/trip. Now Fuse #8 and #10 no voltage. Had to remove fuse #11 because of constant chime and battery drain. 

Any clues let me know.

 

Thanks - Paul

 

 

Quote
Topic starter Posted : 02/13/2024 9:14 pm
Serge - UpFix Team
Famed Member Moderator

Thank you for reaching out.  Unfortunately,  we can't do diagnostics over the internet.  You can use a diagnostic scan tool to scan for codes. Or any auto parts store can do it for you for free. After you have it scanned, post the DTC codes here. When you have codes it is easier to determine where the problem is. Or you can have your original part sent to https://www.upfix.com We do repair TIMP. Here is the service link https://www.upfix.com/product-category/repair-return/?make=DODGE&model=1500&year=2007&_gl=1*1vma8rh*_ga*MTg3NTQ2Mzk5MC4xNzA3ODY4NjEz*_ga_VLRWMK55YK*MTcwNzg2ODYxMy4xLjEuMTcwNzg2ODcyMi4wLjAuMA

This post was modified 2 months ago by Serge - UpFix Team
ReplyQuote
Posted : 02/14/2024 12:31 am
Paul Erickson
New Member Registered

I'm having a few other electrical issues not listed on the service page.  Most of what is listed I have an issue with.  Should I still send it in and do you have a coupon code?

ReplyQuote
Topic starter Posted : 02/15/2024 1:35 pm
Serge - UpFix Team
Famed Member Moderator

We do service TIMP for you vehicle   If you have no DTC codes and you not sure of the issue you are having.   Send it in . We can do a bench test for $ 39.99 Upfix   4991 BU Bowman Dr  Buford GA 30518

This post was modified 2 months ago 2 times by Serge - UpFix Team
ReplyQuote
Posted : 02/15/2024 2:14 pm
Paul Erickson
New Member Registered

Ever since I rebooted the TIPM I haven't been able to start the truck so I don't have codes.  It was running before but with no turns, high beams, alarms on cluster or wipers.  The fuse for the radio/ccn or wireless control was removed (#11) .  After I installed a new one I had those things, but it caused battery drain and the front lights stayed on.  After TIPM reboot fuse locations 8 and 10 lost power in any key position.  I'm going to send it in today. Thanks

ReplyQuote
Topic starter Posted : 02/15/2024 3:41 pm
Serge - UpFix Team
Famed Member Moderator

The 02-09 Dodge RAMs are plagued with electrical gremlins. If they hadn't had their TIPM refurbished yet we can see if it's something we can help you with.

it's good that you cleaned the connectors going to the TIPM as there is quite of a plugs going into it. However if the corrosion was severed it's best to check if there is still continuity on those pins especially the powers and grounds going to the Battery.

If it's a Cummins RAM, it's possible that his ECU is also bad as we've seen some with no communication come through our repair shop. If you have an OBDII scan tool that can read the TIPM (central gateway and ECU) those codes would help us in a major way.

This post was modified 2 months ago by Serge - UpFix Team
ReplyQuote
Posted : 02/16/2024 9:02 pm
Share: